[pypy-issue] Issue #2512: pypy2 5.6/5.7 regression (pypy/pypy)

Pete Vine issues-reply at bitbucket.org
Thu Mar 23 11:38:35 EDT 2017


New issue 2512: pypy2 5.6/5.7 regression
https://bitbucket.org/pypy/pypy/issues/2512/pypy2-56-57-regression

Pete Vine:

Can't translate pypy2 any more, targeting the slowpath backend:

```
[translation:info] Error:
   File "/home/guest/pypy2-v5.7.0-src/rpython/translator/goal/translate.py", line 318, in main
    drv.proceed(goals)
   File "/home/guest/pypy2-v5.7.0-src/rpython/translator/driver.py", line 551, in proceed
    result = self._execute(goals, task_skip = self._maybe_skip())
   File "/home/guest/pypy2-v5.7.0-src/rpython/translator/tool/taskengine.py", line 114, in _execute
    res = self._do(goal, taskcallable, *args, **kwds)
   File "/home/guest/pypy2-v5.7.0-src/rpython/translator/driver.py", line 278, in _do
    res = func()
   File "/home/guest/pypy2-v5.7.0-src/rpython/translator/driver.py", line 361, in task_pyjitpl_lltype
    backend_name=self.config.translation.jit_backend, inline=True)
   File "/home/guest/pypy2-v5.7.0-src/rpython/jit/metainterp/warmspot.py", line 72, in apply_jit
    warmrunnerdesc.finish()
   File "/home/guest/pypy2-v5.7.0-src/rpython/jit/metainterp/warmspot.py", line 288, in finish
    self.annhelper.finish()
   File "/home/guest/pypy2-v5.7.0-src/rpython/rtyper/annlowlevel.py", line 218, in finish
    self.finish_annotate()
   File "/home/guest/pypy2-v5.7.0-src/rpython/rtyper/annlowlevel.py", line 238, in finish_annotate
    ann.complete_helpers()
   File "/home/guest/pypy2-v5.7.0-src/rpython/annotator/annrpython.py", line 116, in complete_helpers
    self.complete()
   File "/home/guest/pypy2-v5.7.0-src/rpython/annotator/annrpython.py", line 229, in complete
    raise annmodel.AnnotatorError(text)
[translation:ERROR] AnnotatorError: 

Blocked block -- operation cannot succeed

    v3484 = getattr(self_291, ('element_ones'))

In <FunctionGraph of (rpython.jit.backend.x86.vector_ext:332)Assembler386.flush_vec_cc at 0x48eb1cd0>:
Happened at file /home/guest/pypy2-v5.7.0-src/rpython/jit/backend/x86/vector_ext.py line 345

==>             self.mc.MOVAPD(maskloc, heap(self.element_ones[get_scale(size)]))
                self.mc.PXOR(resloc, resloc)
                # note that resloc contains true false for each element by the last compare operation
                self.mc.PBLENDVB_xx(resloc.value, maskloc.value)

Known variable annotations:
 self_291 = SomeInstance(can_be_None=False, classdef=rpython.jit.backend.x86.assembler.Assembler386)
``` 

In other words, pypy2 `5.6` or `5.7` can't be translated with `--jit-backend=x86-without-sse2` any longer.




More information about the pypy-issue mailing list