[py-dev] naming issues
ralf at systemexit.de
Fri Aug 3 09:53:37 CEST 2012
holger krekel <holger at merlinux.eu> writes:
> If we are to optionally allow pytest_funcarg__ naming with @pytest.factory
> i wonder if renaming @pytest.factory to @pytest.funcarg would make sense
> and contribute to the notion that pytest-2.3 just extends funcarg
> facilities. The reason i favored @factory is that it really marks a
> factory function whereas "funcarg" more denotes the argument in a test
> or setup function. Moreover, the pytest-2.2 documentation already talked
> about factories when refering to pytest_funcarg__ functions.
> (And @funcargfactory seems a tad long to me).
> However, i can't claim to have much of an outside view so i am interested
> in your and other opinions.
+1 for @pytest.funcarg (mostly because I like to grep for it)
More information about the Pytest-dev