[Python-3000] genexp syntax for reduce

Guido van Rossum guido at python.org
Wed Apr 19 19:22:24 CEST 2006

On 4/19/06, Boris Borcic <bborcic at gmail.com> wrote:
> Guido van Rossum wrote:
> > I wouldn't recommend this approach to anyone.
> What about a variation ?

I haven't seen any convincing argument showing that this feature is
useful or that the code becomes more readable when this feature is
used. Without such arguments it doesn't matter whether you can come up
with unambiguous syntax or anything else.

Personally, I believe that all code involving reduce() can be made
more readable by removing the reduce() call and writing an explicit
loop. Your attempts seem to confirm that alternatives aren't any

--Guido van Rossum (home page: http://www.python.org/~guido/)

More information about the Python-3000 mailing list