[Python-3000] educational aspects of Python 3000

Talin talin at acm.org
Tue Sep 12 04:48:39 CEST 2006

Guido van Rossum wrote:
>>>>> from scripting import raw_input, autotextfile
> I'm not so keen on 'scripting' as the name either, but I'm sure we can
> come up with something. Perhaps easyio, simpleio or basicio? (Not to
> be confused with vbio. :-)
> I'm also not completely against revising the decision on killing
> raw_input(). While input() must definitely go, raw_input() might
> survive under a new name. Too bad calling it input() would be too
> confusing from a Python 2.x POV, and I don't want to call it
> readline() because it strips the trailing newline and raises EOF on
> error. Unless the educators can line with having to use
> readline().strip() instead of raw_input()...?

How about calling it 'ask'?

 >>> s = ask( "How are you today?" )
--> Fine
 >>> s

And as far as the name of a library goes how about "quickstart"? Other 
possibilities are: quickstudy, kickstart, simplestart, etc.

"With the Python quickstart module, programming is as easy as 

-- Talin

More information about the Python-3000 mailing list