[Python-3000] educational aspects of Python 3000

Nick Coghlan ncoghlan at gmail.com
Tue Sep 12 15:45:44 CEST 2006

Brett Cannon wrote:
> On 9/11/06, *Michael Chermside* <mcherm at mcherm.com 
>     Personally, I think input() should never have existed and must go
>     no matter what.
> Agreed.  Teach the folks eval() quick if you want something like that.

The world would probably be a happier place if you taught them int() and 
float() instead, though :)

>     I think raw_input() is worth discussing -- I wouldn't
>     need it, but it's little more than a convenience function.
> Yeah, but when you are learning it's cool to take input easily.  I loved 
> raw_input() when I started out.

We could always rename raw_input() to input(). Just a thought. . .


Nick Coghlan   |   ncoghlan at gmail.com   |   Brisbane, Australia

More information about the Python-3000 mailing list