[Python-3000] educational aspects of Python 3000

Toby Donaldson tjd at sfu.ca
Tue Sep 12 18:51:18 CEST 2006

On 9/12/06, Raymond Hettinger <rhettinger at ewtllc.com> wrote:
>  We could always rename raw_input() to input(). Just a thought. . .
>  D'oh. Guido already said he doesn't like that idea :)
>  FWIW, I think it is a good idea.  If there is a little 2.x vs 3.0
> confusion, so be it.   The use of input() function is already somewhat rare
> (both because of infrequent use cases and because of the stern warnings
> about eval's security issues).  It is better to bite the bullet and move on
> than it would be to avoid the most obvious name.

I agree ... "input" is perhaps the best name from a beginners point of
view, and it is only a minor inconvenience for experienced

Dr. Toby Donaldson
School of Computing Science
Simon Fraser University (Surrey)

More information about the Python-3000 mailing list