[Python-3000] educational aspects of Python 3000
rrr at ronadam.com
Tue Sep 12 23:03:30 CEST 2006
Raymond Hettinger wrote:
>>> We could always rename raw_input() to input(). Just a thought. . .
>> D'oh. Guido already said he doesn't like that idea :)
> FWIW, I think it is a good idea. If there is a little 2.x vs 3.0
> confusion, so be it. The use of input() function is already somewhat
> rare (both because of infrequent use cases and because of the stern
> warnings about eval's security issues). It is better to bite the bullet
> and move on than it would be to avoid the most obvious name.
Maybe "input" can be depreciated in 2.x with a messages to use eval(raw_input())
instead. That would limit some of the confusion.
More information about the Python-3000