[Python-3000] [Python-checkins] r53276 - peps/trunk/pep-3108.txt
Jim Jewett
jimjjewett at gmail.com
Fri Jan 5 23:16:48 CET 2007
> +PEP 8 specifies that modules "should have short, all-lowercase names"
> +where "underscores can be used ... if it improves readability"
> +[#pep-0008]_. The use of underscores is discouraged in package names.
...
> -BaseHTTPServer basehttpserver
> +BaseHTTPServer base_http_server
> -CGIHTTPServer cgihttpserver
> +CGIHTTPServer cgi_http_server
And so we circle round to (namespace) packages, because is a dot
really any worse than an underscore?
http.server.base
http.server.cgi
http.server.simple
I had thought Guido had said "no", as a matter of scope creep, but
this rename doesn't seem to be any more disruptive than
base_http_server.
On the other hand, I'm used to
>>> from package.subpackage.module import Class1 as C1, func_abcde as myfunc
If I correctly read a recent note on google standards, then there are
people who can't rename on import, and might be stuck using several
dots (or worse, writing the semi-generic "server.base") on every
reference.
-jJ
More information about the Python-3000
mailing list