[Python-3000] PEP: rename it.next() to it.__next__(), add a next() built-in

Ka-Ping Yee python-dev at zesty.ca
Mon Mar 5 23:36:00 CET 2007


On Mon, 5 Mar 2007 python at rcn.com wrote:
> And, more importantly, it is butt-ugly.

What part exactly?  Does this bother you:

    def __next__(self):
        ...

or this:

    while whatever:
        x = next(i)
        ...

They look pretty much like the rest of Python to me.


-- ?!ng


More information about the Python-3000 mailing list