[Python-3000] PEP: rename it.next() to it.__next__(), add a next() built-in
Greg Ewing
greg.ewing at canterbury.ac.nz
Mon Mar 5 23:45:18 CET 2007
Ka-Ping Yee wrote:
> Just like getattr, two-argument next(iter, sentinel)
> returns sentinel if StopException is caught.
+1. I've written a number of pieces of code where this
would have made things neater. Just about any place
where I've used .next() explicitly, in fact -- it
always seems awkward having to deal with StopIteration.
--
Greg
More information about the Python-3000
mailing list