[Python-3000] need help fixing broken tests in py3k-pep3137 branch
Guido van Rossum
guido at python.org
Sun Nov 4 01:00:51 CET 2007
On 11/3/07, Jim Jewett <jimjjewett at gmail.com> wrote:
> On 11/3/07, Guido van Rossum <guido at python.org> wrote:
> > I'd love a better term. It seems we could use several new names:
> > 1. a new name for what PEP 3137 calls buffer
Fails the rule that built-in types have all-lowercase names. I've been
thinking to call it bytesbuffer or bytes_buffer though.
> > 2. a new name for the union of bytes and buffer (*)
That could work, it's an ABC after all (to be imported from collections).
> > 3. a new name for all types supporting the "buffer API"
Another ABC, so should have a CamelCase name. Also, we probably
shouldn't use plain, unadorned "buffer" or "Buffer" for any of these
-- it has too many meanings. Also "buffer" is a popular variable name
(much more so than bytes).
--Guido van Rossum (home page: http://www.python.org/~guido/)
More information about the Python-3000