ZODB 3.3 beta 1 released

Tim Peters tim@zope.com
Mon, 7 Jun 2004 16:31:32 -0400

I'm pleased to announce the release of ZODB 3.3 beta 1.  As always with the
first beta release, the feature set for ZODB 3.3 is frozen now.

The ZODB 3.3b1 release requires Python 2.3.3.  Python 2.3.4 is recommended,
and will be required for ZODB 3.3 final.  This version of ZODB supports Zope
2 and Zope 3.  ZODB 3.3b1 matches the ZODB code included in the
ZopeX3-3.0.0b1 release, and contains code that will be released in Zope 2.8.

You can download a source tarball or Windows installer from:


The changes since ZODB 3.3a3 consist mostly of fixes for longstanding ZODB
bugs, several of which were backported to the Zope 2.7 maintenance branch.
The news file lists the changes in more detail:


Since ZODB 3.3 will be at the heart of database operations in Zope 2.8 and
Zope 3, it's important that it be tested as broadly as possible.  Please
download it and give it a try!