[ANN] PyInstaller 1.1 released

Giovanni Bajo rasky at develer.com
Mon Feb 13 16:25:45 CET 2006

PyInstaller 1.1

PyInstaller 1.1 has been released! This release has been composed also with
the help of patches provided by the community: many thanks to everybody!

Find the downloads at the usual locations:

http://pyinstaller.hpcf.upr.edu  (website)

ChangeLog for this release:

 + (Windows) Make single-file packages not depend on MSVCRT71.DLL anymore,
   even under Python 2.4. You can eventually ship your programs really as
   single-file executables, even when using the newest Python version!
 + Fix problem with incorrect python path detection. Now using helpers from
 + Fix problem with rare encodings introduced in newer Python versions: now
   the encodings are automatically found and included, so this problem
   be gone forever.
 + Fix building of COM servers (was broken in 1.0 because of the new build
 + Mimic Python 2.4 behaviour with broken imports: sys.modules is cleaned up
   afterwise. This allows to package SQLObject applications under Windows
   with Python 2.4 and above.
 + Add import hook for the following packages:
     + GTK
     + PyOpenGL (tested
     + dsnpython (tested 1.3.4)
     + KInterasDB (courtesy of Eugene Prigorodov)
 + Fix packaging of code using "time.strptime" under Python 2.3+.
 + (Linux) Ignore linux-gate.so while calculating dependencies (fix provided
   by Vikram Aggarwal).
 + (Windows) With Python 2.4, setup UPX properly so to be able to compress
   binaries generated with Visual Studio .NET 2003 (such as most of the
   extensions). UPX 1.92+ is needed for this.

Giovanni Bajo

More information about the Python-announce-list mailing list