Version 1.2 of mod_wsgi is now available.

Graham Dumpleton Graham.Dumpleton at
Wed Oct 31 11:18:14 CET 2007

Version 1.2 of mod_wsgi is now available. The software and
documentation are both available from:

The mod_wsgi package consists of an Apache web server module designed
and implemented specifically for hosting Python based web applications
that support the WSGI interface specification.

Examples of major Python web frameworks and applications which are
known to work in conjunction with mod_wsgi include CherryPy, Django,
MoinMoin, Pylons, Trac and TurboGears.

Version 1.2 of mod_wsgi is a bug fix only release, addressing issues
with WSGI specification compliance, sub process invocation from Python
in a mod_wsgi daemon process and most importantly of all, an issue
whereby a second sub interpreter instance could be created for each
WSGI application group when targeted by a specifically formed URL.

This latter issue of a second sub interpreter being created only
affects users of Apache 1.3 and 2.0. Because it can have the affect of
doubling the memory in use by the application, it is highly
recommended that users of these Apache versions upgrade to mod_wsgi
1.2, given that in a memory constrained environment the bug could be
exploited as a form of remote denial of service attack.

A description of all changes in this version can be found in the
change notes at:

If you have any questions about mod_wsgi or wish to provide feedback,
use the Google group for mod_wsgi found at:


Graham Dumpleton

More information about the Python-announce-list mailing list