[ANNOUNCE] PyGobject 2.18.0 - stable

Gian Mario Tagliaretti gianmt at gnome.org
Mon May 25 00:01:34 CEST 2009

I am pleased to announce version 2.18.0 of the Python bindings for GObject.

The new release is available from ftp.gnome.org as and its mirrors
as soon as its synced correctly:


What's new since PyGObject 2.17.0?
        - Improve gio docs with some more classes (Gian)
        - Wrap gio.OutputStream.splice_async() (Gian)
        - Add Python ver into installed libpyglib name (Emilio Pozuelo Monfort)
        - Wrap gio.OutputStream.flush_async() (Gian)
        - Use 'Requires.private' for libffi in '.pc' files (Josselin Mouette)
        - Add wrapper for gio.FileAttributeMatcher (Gian)
        - Mark relevant glib.IOChannel methods as METH_NOARGS (Paul)
        - Retire hand-written ChangeLog; autocreate from Git history (Paul)
        - Wrap gio.InputStream.skip_async() (Gian)
        - Add in codegen -n --namespace option and the code to remove dll
          API in headers, added documentation (Siavash Safi)
        - Properly mark glib.get_user_special_dir() as a keywords method (Paul)


GObject is a object system library used by GTK+ and GStreamer.

PyGObject provides a convenient wrapper for the GObject library for use
in Python programs, and takes care of many of the boring details such as
managing memory and type casting.  When combined with PyGTK, PyORBit and
gnome-python, it can be used to write full featured Gnome applications.

Like the GObject library itself PyGObject is licensed under the
GNU LGPL, so is suitable for use in both free software and proprietary
applications.  It is already in use in many applications ranging
from small single purpose scripts up to large full
featured applications.

PyGObject requires glib >= 2.14.0 and Python >= 2.3.5 to build.
GIO bindings require glib >= 2.16.0.

Gian Mario Tagliaretti
GNOME Foundation member
gianmt at gnome.org

More information about the Python-announce-list mailing list