oejskit 0.8.9, javascript testing support, consolidation release

Samuele Pedroni samuele.pedroni at gmail.com
Mon Nov 29 21:30:20 CET 2010

I have just uploaded to pypi a new release 0.8.9 of oejskit, this is
just a consolidation release.

The main changes it that it is packaged as source tarball, making it
easier to install with Python 2.7, and that it drops support for
Python 2.5.

This release doesn't support yet py.test 2.0, I have started
investigating what is required to support it, it will take a bit of time to
release something working with it.

unittest.py support is working and unchanged.

About OE jskit:

jskit contains infrastructure and in particular a py.test plugin to
enable running unit tests for JavaScript code inside browsers.
It contains also glue code to run JavaScript tests from unittest.py
based test suites.

The approach also enables to write integration tests such that the
JavaScript code is tested against server-side Python code mocked as
necessary. Any server-side framework that can already be exposed through
WSGI can play.

The plugin requires py.test 1.3.4 or slightly older.

More information and downloading at:


including a changelog and  documentation.

regards, Samuele Pedroni

More information about the Python-announce-list mailing list