[Python-bugs-list] [Bug #123225] asyncore.py should use select.poll(), not "import poll"

noreply@sourceforge.net noreply@sourceforge.net
Mon, 27 Nov 2000 13:17:28 -0800


Bug #123225, was updated on 2000-Nov-22 20:41
Here is a current snapshot of the bug.

Project: Python
Category: Library
Status: Open
Resolution: None
Bug Group: Not a Bug
Priority: 5
Summary: asyncore.py should use select.poll(), not "import poll"

Details: The Python2.0 asyncore module is able to use the poll system call
(claimed to be much more efficient than select for large numbers of requests),
however, it tries to "import poll", which fails (there is no pollmodule supplied with Python2.0), whereas it could
use the poll available with the select module (select.poll()).



For detailed info, follow this link:
http://sourceforge.net/bugs/?func=detailbug&bug_id=123225&group_id=5470