[Python-bugs-list] [ python-Bugs-595105 ] AESend on Jaguar

noreply@sourceforge.net noreply@sourceforge.net
Mon, 19 Aug 2002 07:45:48 -0700

Bugs item #595105, was opened at 2002-08-14 18:02
You can respond by visiting: 

Category: Macintosh
Group: Python 2.3
Status: Open
Resolution: None
Priority: 5
Submitted By: Alexandre Parenteau (aubonbeurre)
Assigned to: Jack Jansen (jackjansen)
Summary: AESend on Jaguar

Initial Comment:
I wonder how many of you guys played with Jaguar 
(OSX 10.2). It is also my
first glance at gcc 3.1 that comes with 10.2. Everything 
was fine for
building Python, except for waste which has an 
obsolete libWaste.a (even in
August 1st Waste 2.1b1) which won't compile with 
gcc3.1. After I recompiled
waste with CodeWarrior 8.2 (MPTP: early access), it 
came OK.

I then run into some problems of checked out files 
because I'm using MacCvs
(see earlier message). I used the 'make 
frameworkinstall' scheme.

Now I'm experiencing the nice new architecture. I 
mostly use python from the
command line to invoke CodeWarrior thru AppleScripts, 
so I almost immeditly
run into a hanging problems of python :

        _err = AESend(&_self->ob_itself,

I had to comment out upp_AEIdleProc (I tried several 
things, but that is the
only thing which helped). Jack, you might want to 
remember this one if the
problem is still in Jaguar. It hangs and finally times out. 
I've looked
inside this function and I can see the signal handling, 
but I'm not sure
what it is for.


>Comment By: Jack Jansen (jackjansen)
Date: 2002-08-19 16:45

Logged In: YES 

I tried a few simple things with the AE module (talking to CodeWarrior) 
on Jaguar, but I can't get it to hang.

Could you give me an example script that shows the problem?

Also: I've been using MachoPython from the CVS HEAD, I assume 
you're using the same, right?


You can respond by visiting: