[Python-bugs-list] [ python-Bugs-630195 ] bdist_rpm target breaks with rpm 4.1

noreply@sourceforge.net noreply@sourceforge.net
Mon, 04 Nov 2002 05:20:09 -0800


Bugs item #630195, was opened at 2002-10-28 19:30
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=105470&aid=630195&group_id=5470

Category: Distutils
Group: Python 2.2.1
>Status: Closed
>Resolution: Fixed
Priority: 5
Submitted By: Malcolm Tredinnick (malcolmt)
Assigned to: Nobody/Anonymous (nobody)
Summary: bdist_rpm target breaks with rpm 4.1

Initial Comment:
In order to make the bdist_rpm target in distutils work
with a broader range of rpm versions, it is necessary
to use the 'rpmbuild' command, rather than 'rpm' to
build rpms. 

Using 'rpm -ba ...' has been deprecated for a couple of
years and is no longer part of rpm 4.1 (which is
distributed by default with Red Hat 8.0 a.o.).

The attached patch fixes this.

----------------------------------------------------------------------

>Comment By: A.M. Kuchling (akuchling)
Date: 2002-11-04 08:20

Message:
Logged In: YES 
user_id=11375

Fixed in CVS by Sean Reifschneider; his patch is safer, using rpmbuild if present and falling back to rpm.  Thanks!


----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=105470&aid=630195&group_id=5470