[Python-bugs-list] [ python-Bugs-604128 ] time.struct_time undocumented

noreply@sourceforge.net noreply@sourceforge.net
Wed, 13 Nov 2002 11:06:33 -0800


Bugs item #604128, was opened at 2002-09-03 14:49
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=105470&aid=604128&group_id=5470

Category: Extension Modules
Group: Python 2.3
>Status: Closed
>Resolution: Fixed
Priority: 5
Submitted By: Barry A. Warsaw (bwarsaw)
Assigned to: Fred L. Drake, Jr. (fdrake)
Summary: time.struct_time undocumented

Initial Comment:
The time module has a mystery name <wink> called
"struct_time" which is undocumented.  It is used in a
couple of places such as imaplib.py, test_structseq.py
and test_strptime.py.  It should be documented.

----------------------------------------------------------------------

>Comment By: Fred L. Drake, Jr. (fdrake)
Date: 2002-11-13 14:06

Message:
Logged In: YES 
user_id=3066

We'll skip renaming the type for now, since there's no
consistency regarding the names of the "structured sequence"
types.  Since the type was already named and released in the
2.2.x series, we can't really get rid of the old name anyway.

I've updated the documentation to reflect the addition of
the struct_time type and the attribute names for fields in
Doc/lib/libtime.tex revisions 1.51 and 1.48.6.2.

----------------------------------------------------------------------

Comment By: Brett Cannon (bcannon)
Date: 2002-11-02 14:47

Message:
Logged In: YES 
user_id=357491

If an agreement can be reached on what it should be renamed to (I 
thought we had agreed on a name already?  I, of course, don't have the 
email to prove this, though), I am willing to help grep Lib/ and generate 
patches to replace the calls with the new name (and I will even use 
unified diffs this time! =).

Personally, I think TimeStructType is fine, but we must make sure that 
it won't be mistaken for the forthcoming datetime type.  I would wager 
that the datetime type would have something named DateTimeType if 
there is going to be a name that might conflict.

I am also willing to write the blurb to document this sucker.

----------------------------------------------------------------------

Comment By: Barry A. Warsaw (bwarsaw)
Date: 2002-09-03 21:57

Message:
Logged In: YES 
user_id=12800

It should also be renamed to be something like TimeStructType.


----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=105470&aid=604128&group_id=5470