[ python-Bugs-883283 ] bundlebuilder --lib mishandles frameworks

SourceForge.net noreply at sourceforge.net
Fri Jul 16 18:45:49 CEST 2004

Bugs item #883283, was opened at 2004-01-23 12:44
Message generated for change (Comment added) made by reowen
You can respond by visiting: 

Category: Macintosh
Group: Python 2.3
Status: Closed
Resolution: Works For Me
Priority: 5
Submitted By: Russell Owen (reowen)
Assigned to: Jack Jansen (jackjansen)
Summary: bundlebuilder --lib mishandles frameworks

Initial Comment:
The bundlebuilder command-line argument --lib is supposed to be able to include frameworks in the resulting Mac app. Unfortunately, the aliases in the resulting framework copy are all broken.

For an example of this, use --lib to include Tcl.framework and then look through the framework in the resulting application package. Frameworks normally have quite a few handy aliases (such as .../Versions/Current) and all the aliases I tried were broken.

I'm not entirely sure if this actually breaks anything. The one app I've managed to build with standalone=True and use of --lib to include the Tk and Tcl frameworks runs fine on my Mac (which has Python, Tcl and Tk frameworks installed) but fails with "True undefined" on another Mac running Jaguar that I happened to have handy.

This 2nd problem may be a separate bug or user error on my part. I'm not yet sure.


>Comment By: Russell Owen (reowen)
Date: 2004-07-16 09:45

Logged In: YES 

I see. I also can follow the links using the unix command line. However, I 
cannot follow them using Finder. The links in the original packages *can* be 
followed in Finder, which is why I thought things were seriously broken.

So there is a bug in bundlebuilder (or it is exposing a bug in Finder), but its 
more cosmetic than functional. Still...it'd be nice to have normal Finder 
navigation work if the problem is fixable.


Comment By: Jack Jansen (jackjansen)
Date: 2004-07-15 08:24

Logged In: YES 

I cannot repeat this, neither with 2.4a1 nor with 2.3: I always get 
symlinks where they are expected. I tried the following command line 
(with test.py being a simple hello world script), on MacOS 10.3.4 with 
apple-installed Python:

/usr/bin/python /System/Library/Frameworks/Python.framework/
Versions/2.3/lib/python2.3/plat-mac/bundlebuilder.py -m test.py --lib /
Library/Frameworks/Tcl.framework build

and I got symlinks just fine. Feel free to reopen the bug report if you 
have more info.


You can respond by visiting: 

More information about the Python-bugs-list mailing list