[ python-Bugs-1048900 ] Registry not updated by 2.4b1 installer

SourceForge.net noreply at sourceforge.net
Tue Oct 19 21:24:15 CEST 2004


Bugs item #1048900, was opened at 2004-10-18 01:00
Message generated for change (Comment added) made by loewis
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=105470&aid=1048900&group_id=5470

Category: Windows
Group: Python 2.4
Status: Open
Resolution: None
Priority: 5
Submitted By: B Sizer (kylotan)
Assigned to: Nobody/Anonymous (nobody)
Summary: Registry not updated by 2.4b1 installer

Initial Comment:
Running the python-2.4b1.msi installer on Win98 SE
appeared to proceeded as expected. However, the
registry appears not to have been updated and any
add-on Python library installers are still asking to be
put in my old Python 2.3 directory, effectively
preventing me from using those libraries with 2.4b, or
any scripts that rely on them.

----------------------------------------------------------------------

>Comment By: Martin v. Löwis (loewis)
Date: 2004-10-19 21:24

Message:
Logged In: YES 
user_id=21627

I cannot reproduce this on XPSP2. Can you please use
regedit.exe to find out
a) whether HKEY_LOCAL_MACHINE\Software\Python exists, and
b) if so, what its subkeys are? In particular, is anything
about 2.4 present?

If installers choose 2.3, it might be that they have
extension modules which need to be recompiled for 2.4, in
which case the installer specifically looks for a 2.3
installation, rather than the latest installation.

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=105470&aid=1048900&group_id=5470


More information about the Python-bugs-list mailing list