[issue3051] heapq change breaking compatibility

Jean-Paul Calderone report at bugs.python.org
Wed Jun 11 15:50:18 CEST 2008

Jean-Paul Calderone <exarkun at divmod.com> added the comment:

Thanks for the explanation.  Unfortunately, even if we change our code
to work with the new requirements, all the old code is still out there.
 Maybe this doesn't matter, since there are so many other
incompatibilities between Python 2.5 and Python 2.6.  And there aren't
many cases where the extension module isn't available, anyway.  It will
be surprising and probably hard to debug if anyone runs into this, but I
suppose it's possible that no one will.

Python tracker <report at bugs.python.org>

More information about the Python-bugs-list mailing list