[issue3088] test_multiprocessing hangs on OS X 10.5.3

Guido van Rossum report at bugs.python.org
Thu Jun 12 16:07:51 CEST 2008

Guido van Rossum <guido at python.org> added the comment:

If it's only failing during the second run of "make test", typically
there's some implicit dependency on something that is disturbed by
running a test that's later in the suite of tests.  This could be either
the fault of that other test (not restoring some global setting or
environment var) or the fault of the test that fails (making unwarranted
assumptions or not initializing some needed settings before starting).

If it works for some folks and not for others, on the same platform,
compare the set of extension modules that are not built, reported by
"make" in a message starting with "Failed to find the necessary bits to
build these modules:". Likely, Barry has the most complete set, while
Jesse has a few more extensions missing.

Finding this is usually a painful process of bisecting the set of tests
run.  Randomizing the tests with regrtest.py -r might also be helpful.

FWIW, when I tried (on Leopard) "make test
TESTOPTS=test_multiprocessing" it hung on the first set.  When I ran
"./python Lib/test/test_multiprocess.py -v" it reported 122 tests
passed.  But when I ran "./python Lib/test/regrtest.py -v
test_multiprocessing" one test failed:

ERROR: test_remote (test.test_multiprocessing.WithManagerTestRemoteManager)
Traceback (most recent call last):
  File "/Users/guido/p/Lib/test/test_multiprocessing.py", line 1167, in
    queue = manager2.get_queue()
  File "/Users/guido/p/Lib/multiprocessing/managers.py", line 650, in temp
    authkey=self._authkey, exposed=exp
  File "/Users/guido/p/Lib/multiprocessing/managers.py", line 902, in
  File "/Users/guido/p/Lib/multiprocessing/managers.py", line 711, in
  File "/Users/guido/p/Lib/multiprocessing/managers.py", line 758, in
    dispatch(conn, None, 'incref', (self._id,))
  File "/Users/guido/p/Lib/multiprocessing/managers.py", line 94, in
    raise convert_to_error(kind, result)
Traceback (most recent call last):
  File "/Users/guido/p/Lib/multiprocessing/managers.py", line 196, in
    result = func(c, *args, **kwds)
  File "/Users/guido/p/Lib/multiprocessing/managers.py", line 412, in incref
    self.id_to_refcount[ident] += 1
KeyError: '5f2828'

nosy: +gvanrossum

Python tracker <report at bugs.python.org>

More information about the Python-bugs-list mailing list