[issue3944] faster long multiplication
Mark Dickinson
report at bugs.python.org
Tue Mar 24 11:07:48 CET 2009
Mark Dickinson <dickinsm at gmail.com> added the comment:
Updated version of longobject_diff1:
- add mul1 back in
- rename MAX_PARTIALS to the more descriptive BLOCK_MUL_SIZE
- rewrite digits_multiply so that the call to digits_multiply_add
always has b_size=BLOCK_MUL_SIZE, then hard-code this and get
rid of the b_size argument. This should give the compiler some
opportunities for loop-unrolling in digits_multiply_add.
----------
Added file: http://bugs.python.org/file13406/faster_long_mul.patch
_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue3944>
_______________________________________
More information about the Python-bugs-list
mailing list