[issue8108] test_ftplib fails with OpenSSL 0.9.8m

Giampaolo Rodola' report at bugs.python.org
Mon Apr 5 20:25:40 CEST 2010

Giampaolo Rodola' <billiejoex at users.sourceforge.net> added the comment:

Yes, it's the _sslobj.shutdow() call:

  File "test_ftplib.py", line 332, in handle_close
    self.socket = self.socket.unwrap()
  File "/usr/local/lib/python2.7/ssl.py", line 258, in unwrap
    s = self._sslobj.shutdown()
error: [Errno 0] Error

Since it's not clear to me where exactly this comes from, whether it's from the Python C binding or OpenSSL itself, I tried to put some debugging printf() calls in Modules/_ssl.c, but it seems that  after installing OpenSSL 0.9.8m I'm no longer able to compile Python 2.7 from sorces.
This is what I get when I run ./configure; make:

gcc -pthread -fPIC -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I. -IInclude -I./Include -I/usr/local/include -I/home/giampaolo/svn/python-2.7/Include -I/home/giampaolo/svn/python-2.7 -c /home/giampaolo/svn/python-2.7/Modules/_ssl.c -o build/temp.linux-i686-2.7/home/giampaolo/svn/python-2.7/Modules/_ssl.o
gcc -pthread -shared build/temp.linux-i686-2.7/home/giampaolo/svn/python-2.7/Modules/_ssl.o -L/usr/local/lib -lssl -lcrypto -o build/lib.linux-i686-2.7/_ssl.so
*** WARNING: renaming "_ssl" since importing it failed: build/lib.linux-i686-2.7/_ssl.so: undefined symbol: inflate

nosy:  -jcea
versions: +Python 2.6, Python 3.1

Python tracker <report at bugs.python.org>

More information about the Python-bugs-list mailing list