[issue9045] 2.7rc1: 64-bit OSX installer is not built with 64-bit tkinter

Sridhar Ratnakumar report at bugs.python.org
Fri Jun 25 18:28:54 CEST 2010


Sridhar Ratnakumar <sridharr at activestate.com> added the comment:

On 2010-06-25, at 8:13 AM, Ronald Oussoren wrote:

> Sridhar: building using the 10.5 SDK should also work by using --enable-universalsdk=/Developer/SDKs/MacOSX10.5.sdk. I've recently patched setup.py and distutils to honor the SDK setting when looking for files.

Yes, but that will end up linking with Tcl/Tk 8.4 /inside/ the 10.5sdk; whereas the walkthrough above links to Apple's Tcl/Tk 8.5 built with 64-bit. I do hope - and I am not sure about this (though I have personally verified this by running regrtest) - using MACOSX_DEPLOYMENT_TARGET=10.5 will make the resultant binaries work on a 10.5 machine.

----------

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue9045>
_______________________________________


More information about the Python-bugs-list mailing list