[issue10273] Clean-up Unittest API

R. David Murray report at bugs.python.org
Wed Nov 3 02:31:43 CET 2010

R. David Murray <rdmurray at bitdance.com> added the comment:

I don't think assertLE is enough of an improvement over assertLessEqual to be worth adding yet more deprecated names to unittest. So I'm -0 on this change in general.  (I'd be -1 except that it would be kind of nice to have the names be shorter :)

If the change is made, then assertEqual should become assertEQ, and assertNotEqual should become assertNE.

Another option is to go the other way, and change assertLess to assertLessThan.  That is, make the spelling consistently be the spelled out version of the abbreviation used in the special methods and elsewhere in the docs.  This would involve far fewer name changes.

nosy: +r.david.murray

Python tracker <report at bugs.python.org>

More information about the Python-bugs-list mailing list