[issue10493] test_strptime failures under OpenIndiana

Jesús Cea Avión report at bugs.python.org
Thu Nov 25 17:11:03 CET 2010


Jesús Cea Avión <jcea at jcea.es> added the comment:

I verified that the bug was present too in the py3k patch sometime ago, but not currently. So I have spend some time doing bisection in the py3k branch to know WHEN the problem was solved.

If was solved in r81583:

"""
------------------------------------------------------------------------
r81583 | martin.v.loewis | 2010-05-28 17:44:20 +0200 (Fri, 28 May 2010) | 9 lines

Merged revisions 81582 via svnmerge from 
svn+ssh://pythondev@svn.python.org/python/trunk

........
  r81582 | martin.v.loewis | 2010-05-28 17:28:47 +0200 (Fr, 28 Mai 2010) | 2 lines
  
  Issue #1759169: Drop _XOPEN_SOURCE on Solaris.
........

------------------------------------------------------------------------
"""

The fix was ported from trunk (2.7) to py3k branch, but it was not applied to 3.1 branch, though. I don't know why, but seems to be an oversight.

Since the patch has been "tested" in py3k branch since late May, it is simple and solves the problem in 3.1 branch, I request this patch to be applied to 3.1 too.

Martin, do you have an opinion?.

Must the release manager to be involved?.

PS: I have verified that with the change, the buildslave in OpenIndiana passes the test.

The issue is that we have checks for "SunOS/5.10", but OpenIndiana and the new Solaris 11 Express are "SunOS/5.11". We have to add them.

----------

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue10493>
_______________________________________


More information about the Python-bugs-list mailing list