[issue9750] sqlite3 iterdump fails on column with reserved name

Marko Kohtala report at bugs.python.org
Sun Sep 12 10:57:22 CEST 2010

Marko Kohtala <marko.kohtala at gmail.com> added the comment:

Thank you for the review.

I have very limited time to use on this. So even when I'd like to make everything easy for you, have the time you give to python be as productive as possible, I can not.

But I'll respond to your comments on the patch.

a) I added the quotes to every identifier based on a comment in sqlite documentation "SQLite adds new keywords from time to time when it takes on new features. So to prevent your code from being broken by future enhancements, you should normally quote any identifier that is an English language word, even if you do not have to." While fixing one place, I fixed it to follow this recommendation in other places as well.

b) I added quotes using backslashes because it was consistent. The table name was already quoted like that. I agree it could be clearer.

c) I know. I only tried to make minimal changes targeted only to the issues at hand. I did not want to hide the fixes in middlde of changes to style.


Python tracker <report at bugs.python.org>

More information about the Python-bugs-list mailing list