[issue12748] IDLE halts on osx when copy and paste

hy report at bugs.python.org
Mon Aug 15 01:55:08 CEST 2011

hy <hoyeung411 at gmail.com> added the comment:

Thank you. I kinda know what happens now.

First, I didn't made any change to IDLE after installed.

Second, I'm using dvorak-qwerty. Normally the keyboard layout changes to qwerty when I press Cmd key so that I can type in Dvorak and use the short cut in qwerty. But in IDLE it's not the same case. I find that the halt problem only occur when I copy. So I tried cut and paste. It happens that I can use both Cmd+x and Cmd+b (x in Dvorak layout) to cut and both Cmd+v and Cmd+.(v in Dvorak layout) to paste. So if I press Cmd+c, I'm inputting both Cmd+c and Cmd+j at the same time. And I think that's the reason why it halts. 

By hang, it's exactly what you described.

Also, i tried Tcl/Tk 8.4, the same problem happens.

It's weird since I don't have this problem in Windows when I use a third-party dvorak-qwerty input method.

I temporally changed to Dvorak now to avoid this problem, although there is a little bit inconvenient since all shortcut has changed.


Python tracker <report at bugs.python.org>

More information about the Python-bugs-list mailing list