[issue11026] Distutils2 install command fail with python 2.5/2.7

Boris FELD report at bugs.python.org
Thu Jan 27 15:35:35 CET 2011


New submission from Boris FELD <lothiraldan at gmail.com>:

Distutils2 install command fail with both python 2.5 and python 2.7 while it works with python 2.6.

$ python -V
python 2.5.4
$ python -m "distutils2.run" install
usage: run.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: run.py --help [cmd1 cmd2 ...]
   or: run.py --help-commands
   or: run.py cmd --help

error: Invalid command install
################################
$ python -V
Python 2.7.1
$ python -m "distutils2.run" install
usage: run.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: run.py --help [cmd1 cmd2 ...]
   or: run.py --help-commands
   or: run.py cmd --help

error: Invalid command install

It fail it a setup.cfg exists or not in the current directory.

----------
assignee: tarek
components: Distutils2
messages: 127192
nosy: Boris.FELD, eric.araujo, tarek, tarek-ziade
priority: normal
severity: normal
status: open
title: Distutils2 install command fail with python 2.5/2.7
versions: Python 2.5, Python 2.7

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue11026>
_______________________________________


More information about the Python-bugs-list mailing list