[issue11626] Py_LIMITED_API on windows: unresolved symbol __imp___PyArg_ParseTuple_SizeT

Rainer Schaaf report at bugs.python.org
Tue Mar 22 10:21:52 CET 2011


Rainer Schaaf <rjs at pdflib.com> added the comment:

fixing this for the next version of course would be acceptable. 

As I can use the extension (not setting Py_LIMITED_API) even with 3.2.0 it is not a big problem. I only loose the benefit of Py_LIMITED_API and will have to release another version of the binding later on.

> Would you prefer to see a compiler error indicating that you are using
> a function not available in 3.2.0 (with an option of opting into 
> 3.2.1+)?

I fear I don't understand exactly what is meant here. For me it was enough to get the linker error telling me it is not working.

----------

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue11626>
_______________________________________


More information about the Python-bugs-list mailing list