[issue9253] argparse: optional subparsers

Benjamin West report at bugs.python.org
Fri Jan 6 19:08:38 CET 2012


Benjamin West <bewest at gmail.com> added the comment:

Ok, Steven, that sounds reasonable.

I checked out git-svn python and started comparing diffs... I'm a little confused.  What version of argparse should be patched to provide this feature?

My HG version from https://code.google.com/p/argparse/ seems to contain a version of argparse 1.2 while, my git-svn checkout of python seems to contain an argparse 1.1.  Should I attempt to bring cpython's version up to date as well, or attempt to strip out the version bump changes?

----------

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue9253>
_______________________________________


More information about the Python-bugs-list mailing list