[issue13007] gdbm 1.9 has new magic that whichdb does not recognize

Niklas Br report at bugs.python.org
Fri Mar 30 18:17:39 CEST 2012

Niklas Br <n.brunberg at gmail.com> added the comment:

Found this:

# Check for GNU dbm
if magic in (0x13579ace, 0x13579acd, 0x13579acf):
    return "dbm.gnu"

I suppose the .dmg pre-packaged installer was insufficient, so I tried to download the source and compile locally, but that didn't help either. Thanks for taking time to check in on this! I will look for help elsewhere and not clog up this Issue anymore.


Python tracker <report at bugs.python.org>

More information about the Python-bugs-list mailing list