[issue22054] Add os.get_blocking() and os.set_blocking() functions

STINNER Victor report at bugs.python.org
Mon Jul 28 14:39:20 CEST 2014


STINNER Victor added the comment:

> Maybe is_something() is a better name than get_something()
> if something is a boolean?

os and socket modules already use getxxx() / setxxx() names:

- os.get_inheritable() / os.set_inheritable()
- os.getuid() / os.setuid()
- os.getgroups() / os.setgroups()
- os.getxattr() os.setxattr()
- socket.gettimeout() / socket.settimeout()
- socket.get_inheritable() / socket.set_inheritable()
- etc.

There is only one "is" function: os.isatty(), but it does not have a "os.settty" method.

----------

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue22054>
_______________________________________


More information about the Python-bugs-list mailing list