[issue27127] Never have GET_ITER not followed by FOR_ITER

Serhiy Storchaka report at bugs.python.org
Sun May 29 15:17:41 EDT 2016


Serhiy Storchaka added the comment:

Interesting.

How it works with continue?

    for x in a:
        if x: continue
        f()

In this case we can use new FOR_ITER instead of JUMP_ABSOLUTE. I would rename FOR_ITER to something more appropriate (maybe containing NEXT or CONTINUE).

How it works with continue in the try block?

    for x in a:
        try:
            if x: continue
            f()
        except Error:
            e()

----------
nosy: +serhiy.storchaka

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue27127>
_______________________________________


More information about the Python-bugs-list mailing list