[Python-checkins] CVS: python/dist/src Makefile.in,1.82,1.83

Guido van Rossum guido@python.org
Tue, 29 Feb 2000 08:38:01 -0500


> Indeed!  IMHO it would make much sense if you (Guido) post a list of 
> this modules (that have been moved to lib-old) as an official annoucement 
> several weeks *BEFORE*  Python 1.6 will come out.

You can already extract this from the updated documetation on the
website (which has a list of obsolete modules).

But you're righ,t it would be good to be open about this.  I'll think
about it.

--Guido van Rossum (home page: http://www.python.org/~guido/)


Return-Path: <fredrik@pythonware.com>
Delivered-To: python-checkins@python.org
Received: from pythonware.com (python-010.pythonware.com [194.18.155.250])
	by dinsdale.python.org (Postfix) with ESMTP id 7D0F81CD1E
	for <python-checkins@python.org>; Tue, 29 Feb 2000 07:47:17 -0500 (EST)
Received: from panik (panik.secret.pythonware.com [194.18.155.242])
	by pythonware.com (8.8.7/8.8.5) with SMTP id OAA00501
	for <python-checkins@python.org>; Tue, 29 Feb 2000 14:59:37 +0100
Message-ID: <00e601bf82b3$62570450$f29b12c2@secret.pythonware.com>
From: "Fredrik Lundh" <fredrik@pythonware.com>
To: <python-checkins@python.org>
References: <m12Ph1W-000CnCC@artcom0.artcom-gmbh.de>
Subject: Re: [Python-checkins] CVS: python/dist/src Makefile.in,1.82,1.83
Date: Tue, 29 Feb 2000 13:49:13 +0100
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
Sender: python-checkins-admin@python.org
Errors-To: python-checkins-admin@python.org
X-BeenThere: python-checkins@python.org
X-Mailman-Version: 1.2 (beta 1)
Precedence: bulk
List-Id: Check-in messages from the Python maintainers <python-checkins.python.org>

Peter Funk wrote:
> > Increase the support level for other obsolete modules a bit: install
> > lib-old by default.  It still isn't in the path by default, but at
> > least it's easier to add to your $PYTHONPATH this way.  (This makes
> > sense because in 1.6 we're much more aggressive with declaring =
modules
> ----------------------------------^^^^^^^^^^^^^^^
> > obsolete.)
>=20
> Indeed!  IMHO it would make much sense if you (Guido) post a list of=20
> this modules (that have been moved to lib-old) as an official =
annoucement=20
> several weeks *BEFORE*  Python 1.6 will come out.

obsoletemodulenanny.py, anyone?

(hey, it worked yesterday ;-)

</F>