[Python-checkins] r53948 - peps/trunk/pep-3100.txt

guido.van.rossum python-checkins at python.org
Mon Feb 26 18:04:05 CET 2007


Author: guido.van.rossum
Date: Mon Feb 26 18:04:01 2007
New Revision: 53948

Modified:
   peps/trunk/pep-3100.txt
Log:
Mark input() -> raw_input() as done (revising the plans).


Modified: peps/trunk/pep-3100.txt
==============================================================================
--- peps/trunk/pep-3100.txt	(original)
+++ peps/trunk/pep-3100.txt	Mon Feb 26 18:04:01 2007
@@ -169,6 +169,8 @@
   ``zip()``, etc.) [zip is done; Neal Norwitz has a patch for range()]
 * Relevant functions should consume iterators (e.g. ``min()``,
   ``max()``) [They already do, since 2.2.]
+* Remove ``input()`` and rename ``raw_input()`` to ``input()``.
+  If you need the old input(), use eval(input()). [done]
 * Introduce ``trunc()``, which would call the ``__trunc__()`` method on its
   argument; suggested use is for objects like float where calling ``__int__()``
   has data loss, but an integral representation is still desired? [8]_
@@ -182,12 +184,10 @@
 * ``compile()``: put in ``sys`` (or perhaps in a module of its own) [2]_
 * ``coerce()``: no longer needed [2]_
 * ``execfile()``, ``reload()``: use ``exec()`` [2]_
-* ``input()``: use ``eval(sys.stdin.readline())`` [2]_ [done]
 * ``intern()``: put in ``sys`` [2]_, [22]_ [done]
 * ``map()``, ``filter()``: use list comprehensions instead??? [1]_, [9]_
   (Actually these can stay.)
 * ``reduce()``: write a loop instead [2]_, [9]_ [done]
-* ``raw_input()``: use ``sys.stdin.readline()`` ??? [2]_ [done]
 * ``xrange()``: use ``range()`` instead [1]_ [See range() above]
 
 


More information about the Python-checkins mailing list