[Python-checkins] r55571 - peps/trunk/pep-0000.txt peps/trunk/pep-3111.txt

neal.norwitz python-checkins at python.org
Fri May 25 08:17:12 CEST 2007


Author: neal.norwitz
Date: Fri May 25 08:17:11 2007
New Revision: 55571

Modified:
   peps/trunk/pep-0000.txt
   peps/trunk/pep-3111.txt
Log:
PEP 3111 (restoring input) has been implemented so mark it Final.

Also wrap some long lines in the PEP.


Modified: peps/trunk/pep-0000.txt
==============================================================================
--- peps/trunk/pep-0000.txt	(original)
+++ peps/trunk/pep-0000.txt	Fri May 25 08:17:11 2007
@@ -77,7 +77,6 @@
  SA  358  The "bytes" Object                           Schemenauer, GvR
  SA 3106  Revamping dict.keys(), .values() & .items()  GvR
  SA 3109  Raising Exceptions in Python 3000            Winter
- SA 3111  Simple input built-in in Python 3000         Roberge
  SA 3112  Bytes literals in Python 3000                Orendorff
  SA 3115  Metaclasses in Python 3000                   Talin
  SA 3119  Introducing Abstract Base Classes            GvR, Talin
@@ -173,6 +172,7 @@
  SF 3105  Make print a function                        Brandl
  SF 3107  Function Annotations                         Winter, Lownds
  SF 3110  Catching Exceptions in Python 3000           Winter
+ SF 3111  Simple input built-in in Python 3000         Roberge
  SF 3113  Removal of Tuple Parameter Unpacking         Cannon
  SF 3114  Renaming iterator.next() to .__next__()      Yee
  SF 3129  Class Decorators                             Winter
@@ -481,7 +481,7 @@
  S  3108  Standard Library Reorganization              Cannon
  SA 3109  Raising Exceptions in Python 3000            Winter
  SF 3110  Catching Exceptions in Python 3000           Winter
- SA 3111  Simple input built-in in Python 3000         Roberge
+ SF 3111  Simple input built-in in Python 3000         Roberge
  SA 3112  Bytes literals in Python 3000                Orendorff
  SF 3113  Removal of Tuple Parameter Unpacking         Cannon
  SF 3114  Renaming iterator.next() to .__next__()      Yee

Modified: peps/trunk/pep-3111.txt
==============================================================================
--- peps/trunk/pep-3111.txt	(original)
+++ peps/trunk/pep-3111.txt	Fri May 25 08:17:11 2007
@@ -3,7 +3,7 @@
 Version: $Revision$
 Last-Modified: $Date$
 Author: Andre Roberge <andre.roberge at gmail.com >
-Status: Accepted
+Status: Final
 Type: Standards Track
 Content-Type: text/x-rst
 Created: 13-Sep-2006
@@ -108,9 +108,9 @@
 Naming Discussion
 =================
 
-With ``input()`` effectively removed from the language, the name ``raw_input()``
-makes much less sense and alternatives should be considered.  The
-various possibilities mentioned in various forums include::
+With ``input()`` effectively removed from the language,
+the name ``raw_input()`` makes much less sense and alternatives should be
+considered.  The various possibilities mentioned in various forums include::
 
   ask()
   ask_user()
@@ -121,8 +121,8 @@
   user_input()
   get_response()
 
-While it was initially rejected by the BDFL, it has been suggested that the most
-direct solution would be to rename "raw_input" to "input" in Python 3000. 
+While it was initially rejected by the BDFL, it has been suggested that the
+most direct solution would be to rename "raw_input" to "input" in Python 3000. 
 The main objection is that Python 2.x already has a function named "input",
 and, even though it is not going to be included in Python 3000,
 having a built-in function with the same name but different semantics may


More information about the Python-checkins mailing list