[Python-checkins] r75801 - python/branches/release26-maint

georg.brandl python-checkins at python.org
Tue Oct 27 16:45:02 CET 2009


Author: georg.brandl
Date: Tue Oct 27 16:45:01 2009
New Revision: 75801

Log:
Blocked revisions 70615,70618-70621,70624,70856,70864,71004,71043,71208,71721,72582-72583,72812,72923,73151,73247,73839,74007,74095,75095 via svnmerge

........
  r70615 | benjamin.peterson | 2009-03-26 20:58:18 +0100 (Do, 26 Mär 2009) | 5 lines
  
  add some useful utilities for skipping tests with unittest's new skipping ability
  
  most significantly apply a modified portion of the patch from #4242 with
  patches for skipping implementation details
........
  r70618 | benjamin.peterson | 2009-03-26 21:48:25 +0100 (Do, 26 Mär 2009) | 1 line
  
  remove test_support.TestSkipped and just use unittest.SkipTest
........
  r70619 | benjamin.peterson | 2009-03-26 21:49:40 +0100 (Do, 26 Mär 2009) | 1 line
  
  fix naming
........
  r70620 | benjamin.peterson | 2009-03-26 22:10:30 +0100 (Do, 26 Mär 2009) | 1 line
  
  fix incorrect auto-translation of TestSkipped -> unittest.SkipTest
........
  r70621 | benjamin.peterson | 2009-03-26 22:11:16 +0100 (Do, 26 Mär 2009) | 1 line
  
  must pass argument to get expected behavior ;)
........
  r70624 | benjamin.peterson | 2009-03-26 22:30:54 +0100 (Do, 26 Mär 2009) | 1 line
  
  ** is required here
........
  r70856 | r.david.murray | 2009-03-31 20:32:17 +0200 (Di, 31 Mär 2009) | 7 lines
  
  A few more test skips via import_module, and change import_module to                                                                                                                                                
  return the error message produced by importlib, so that if an import                                                                                                                                                
  in the package whose import is being wrapped is what failed the skip                                                                                                                                                
  message will contain the name of that module instead of the name of the                                                                                                                                             
  wrapped module.  Also fixed formatting of some previous comments.                                                                                                                                                   
........
  r70864 | gregory.p.smith | 2009-03-31 21:03:28 +0200 (Di, 31 Mär 2009) | 10 lines
  
  Rename the actual method definitions to the official assertFoo names.
  
  Adds unittests to make sure the old fail* names continue to work now
  and adds a comment that they are pending deprecation.
  
  Also adds a test to confirm that the plural Equals method variants
  continue to exist even though we're unlikely to deprecate those.
  
  http://bugs.python.org/issue2578
........
  r71004 | benjamin.peterson | 2009-04-02 01:15:49 +0200 (Do, 02 Apr 2009) | 1 line
  
  remove double underscores
........
  r71043 | michael.foord | 2009-04-02 07:51:54 +0200 (Do, 02 Apr 2009) | 7 lines
  
  Store the functions in the _type_equality_funcs as wrapped objects that are deep copyable.
  
  This allows for the deep copying of TestCase instances.
  
  Issue 5660
........
  r71208 | michael.foord | 2009-04-05 03:15:01 +0200 (So, 05 Apr 2009) | 4 lines
  
  Change the way unittest.TestSuite use their tests to always access them through iteration. Non behavior changing, this allows you to create custom subclasses that override __iter__.
  
  Issue #5693
........
  r71721 | benjamin.peterson | 2009-04-18 21:26:19 +0200 (Sa, 18 Apr 2009) | 1 line
  
  fix a few nits in unittest.py #5771
........
  r72582 | michael.foord | 2009-05-12 12:46:23 +0200 (Di, 12 Mai 2009) | 1 line
  
  Fix to restore command line behaviour for test modules using unittest.main(). Regression caused by issue 5995. Michael
........
  r72583 | michael.foord | 2009-05-12 12:49:13 +0200 (Di, 12 Mai 2009) | 1 line
  
  Better fix for modules using unittest.main(). Fixes regression caused by commit for issue 5995. Michael Foord
........
  r72812 | michael.foord | 2009-05-22 00:57:02 +0200 (Fr, 22 Mai 2009) | 1 line
  
  Rename TestCase._result to _resultForDoCleanups to avoid potential clashes in TestCase subclasses. Issue 6072.
........
  r72923 | michael.foord | 2009-05-25 22:36:56 +0200 (Mo, 25 Mai 2009) | 1 line
  
  Make assertSequenceEqual error messages less cryptic, particularly for nested sequences.
........
  r73151 | michael.foord | 2009-06-02 20:08:27 +0200 (Di, 02 Jun 2009) | 1 line
  
  Restore default testRunner argument in unittest.main to None. Issue 6177
........
  r73247 | michael.foord | 2009-06-05 16:14:34 +0200 (Fr, 05 Jun 2009) | 1 line
  
  Fix unittest discovery tests for Windows. Issue 6199
........
  r73839 | gregory.p.smith | 2009-07-04 10:42:10 +0200 (Sa, 04 Jul 2009) | 3 lines
  
  Merge r73838 from py3k branch.  Use the nondeprecated unittest method
  names.
........
  r74007 | michael.foord | 2009-07-14 19:58:12 +0200 (Di, 14 Jul 2009) | 1 line
  
  Move TestRunner initialisation into unittest.TestProgram.runTests. Fixes issue 6418.
........
  r74095 | benjamin.peterson | 2009-07-19 22:18:21 +0200 (So, 19 Jul 2009) | 1 line
  
  split unittest.py into a package
........
  r75095 | michael.foord | 2009-09-27 21:15:41 +0200 (So, 27 Sep 2009) | 1 line
  
  Test creation moved from TestProgram.parseArgs to TestProgram.createTests exclusively. Issue 6956.
........


Modified:
   python/branches/release26-maint/   (props changed)


More information about the Python-checkins mailing list