[Python-checkins] devguide: #21215: update debian/ubuntu build-dep instructions.

r.david.murray python-checkins at python.org
Tue Apr 15 03:27:33 CEST 2014


http://hg.python.org/devguide/rev/84ccbb961f26
changeset:   687:84ccbb961f26
user:        R David Murray <rdmurray at bitdance.com>
date:        Mon Apr 14 21:27:22 2014 -0400
summary:
  #21215: update debian/ubuntu build-dep instructions.

This update is from Glenn Jones based on his experience following
the instructions while at the PyCon sprints, and also informed by
feedback from Barry Warsaw.

files:
  setup.rst |  10 +++++++---
  1 files changed, 7 insertions(+), 3 deletions(-)


diff --git a/setup.rst b/setup.rst
--- a/setup.rst
+++ b/setup.rst
@@ -107,9 +107,13 @@
    $ sudo yum install yum-utils
    $ sudo yum-builddep python3
 
-Debian, Ubuntu and other ``apt`` based systems::
+Debian, Ubuntu and other ``apt`` based systems, try to get the dependencies for
+the Python version that you're working on e.g.::
 
-   $ sudo apt-get build-dep python3
+   $ sudo apt-get build-dep python3.4
+
+If that package is not available for your system, try reducing the minor
+version until you find a package that is available.
 
 For Mac OS X systems, it is generally easiest to use the C compiler and other
 development utilities provided by Apple's Xcode Developer Tools.  There are
@@ -217,7 +221,7 @@
 Windows
 '''''''
 
-The readme included in the solution has more details, especially on the 
+The readme included in the solution has more details, especially on the
 software needed to resolve the below mentioned build errors.
 
 **Python 3.3** and later use Microsoft Visual Studio 2010.  You can

-- 
Repository URL: http://hg.python.org/devguide


More information about the Python-checkins mailing list