[Python-checkins] [python/cpython] 762ec9: bpo-29204: Emit warnings for already deprecated El...

GitHub noreply at github.com
Thu Mar 30 11:12:09 EDT 2017


  Branch: refs/heads/master
  Home:   https://github.com/python/cpython
  Commit: 762ec97ea68a1126b8855996c61fa8239dc9fff7
      https://github.com/python/cpython/commit/762ec97ea68a1126b8855996c61fa8239dc9fff7
  Author: Serhiy Storchaka <storchaka at gmail.com>
  Date:   2017-03-30 (Thu, 30 Mar 2017)

  Changed paths:
    M Lib/test/test_xml_etree.py
    M Lib/test/test_xml_etree_c.py
    M Lib/xml/etree/ElementTree.py
    M Misc/NEWS
    M Modules/_elementtree.c
    M Modules/clinic/_elementtree.c.h

  Log Message:
  -----------
  bpo-29204: Emit warnings for already deprecated ElementTree features. (#773)

Element.getiterator() and the html parameter of XMLParser() were
deprecated only in the documentation (since Python 3.2 and 3.4 correspondintly).
Now using them emits a deprecation warning.

* Don’t need check_warnings any more.




More information about the Python-checkins mailing list