[Python-checkins] bpo-23156: Remove obsolete tix install directions (GH-11595)

Terry Jan Reedy webhook-mailer at python.org
Thu Jan 17 19:00:55 EST 2019


https://github.com/python/cpython/commit/cf27c06229eb4b8280bb5f2b93a57e33163411f4
commit: cf27c06229eb4b8280bb5f2b93a57e33163411f4
branch: master
author: Terry Jan Reedy <tjreedy at udel.edu>
committer: GitHub <noreply at github.com>
date: 2019-01-17T19:00:51-05:00
summary:

bpo-23156: Remove obsolete tix install directions (GH-11595)

Tix was deprecated in 3.6 and the doc is wrong.  New users should use ttk.

files:
M Doc/library/tkinter.tix.rst

diff --git a/Doc/library/tkinter.tix.rst b/Doc/library/tkinter.tix.rst
index 11ed75513778..88b936c47a6d 100644
--- a/Doc/library/tkinter.tix.rst
+++ b/Doc/library/tkinter.tix.rst
@@ -76,17 +76,6 @@ the following::
    root = tix.Tk()
    root.tk.eval('package require Tix')
 
-If this fails, you have a Tk installation problem which must be resolved before
-proceeding. Use the environment variable :envvar:`TIX_LIBRARY` to point to the
-installed Tix library directory, and make sure you have the dynamic
-object library (:file:`tix8183.dll` or :file:`libtix8183.so`) in  the same
-directory that contains your Tk dynamic object library (:file:`tk8183.dll` or
-:file:`libtk8183.so`). The directory with the dynamic object library should also
-have a file called :file:`pkgIndex.tcl` (case sensitive), which contains the
-line::
-
-   package ifneeded Tix 8.1 [list load "[file join $dir tix8183.dll]" Tix]
-
 
 Tix Widgets
 -----------



More information about the Python-checkins mailing list