[Python-checkins] Doc: Fix: Proper UpperCamelCase and lowercase. (GH-14644)

Miss Islington (bot) webhook-mailer at python.org
Mon Jul 8 17:14:03 EDT 2019


https://github.com/python/cpython/commit/6f5574866c4017e438b7ac5f5374889389c4eb24
commit: 6f5574866c4017e438b7ac5f5374889389c4eb24
branch: 3.7
author: Miss Islington (bot) <31488909+miss-islington at users.noreply.github.com>
committer: GitHub <noreply at github.com>
date: 2019-07-08T14:13:59-07:00
summary:

Doc: Fix: Proper UpperCamelCase and lowercase. (GH-14644)


Initial report by Michael Blankenship on docs@
(cherry picked from commit 2da622ff77a763327895656779370b80a833d95c)

Co-authored-by: Julien Palard <julien at palard.fr>

files:
M Doc/tutorial/controlflow.rst

diff --git a/Doc/tutorial/controlflow.rst b/Doc/tutorial/controlflow.rst
index c3ce1205e52e..482a34399c7b 100644
--- a/Doc/tutorial/controlflow.rst
+++ b/Doc/tutorial/controlflow.rst
@@ -744,7 +744,7 @@ extracted for you:
   bracketing constructs: ``a = f(1, 2) + g(3, 4)``.
 
 * Name your classes and functions consistently; the convention is to use
-  ``CamelCase`` for classes and ``lower_case_with_underscores`` for functions
+  ``UpperCamelCase`` for classes and ``lowercase_with_underscores`` for functions
   and methods.  Always use ``self`` as the name for the first method argument
   (see :ref:`tut-firstclasses` for more on classes and methods).
 



More information about the Python-checkins mailing list