[Python-checkins] bpo-35293: Travis CI uses "make venv" for the doc (GH-22307) (GH-22309)

Victor Stinner webhook-mailer at python.org
Fri Sep 18 10:53:51 EDT 2020


https://github.com/python/cpython/commit/9e73cac173e5e9010bd18c8334fffeee1cade3a4
commit: 9e73cac173e5e9010bd18c8334fffeee1cade3a4
branch: 3.9
author: Victor Stinner <vstinner at python.org>
committer: GitHub <noreply at github.com>
date: 2020-09-18T16:53:46+02:00
summary:

bpo-35293: Travis CI uses "make venv" for the doc (GH-22307) (GH-22309)

Doc/requirements.txt becomes the reference for packages and package
versions needed to build the Python documentation.

* Doc/Makefile now uses Doc/requirements.txt
* .travis.yml now uses "make env" of Doc/Makefile
* Update Sphinx to version 2.4.4

(cherry picked from commit 8394500cca56490cc347604d39ca40abcdce46c3)

files:
M .travis.yml
M Doc/Makefile
M Doc/requirements.txt

diff --git a/.travis.yml b/.travis.yml
index e565f49262fef..5d9f4208e0431 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -51,10 +51,7 @@ matrix:
       env: TESTING=docs
       before_script:
         - cd Doc
-        # Sphinx is pinned so that new versions that introduce new warnings won't suddenly cause build failures.
-        # (Updating the version is fine as long as no warnings are raised by doing so.)
-        # The theme used by the docs is stored separately, so we need to install that as well.
-        - python -m pip install sphinx==2.2.0 blurb python-docs-theme
+        - make venv PYTHON=python
       script:
         - make check suspicious html SPHINXOPTS="-q -W -j4"
     - name: "Documentation tests"
diff --git a/Doc/Makefile b/Doc/Makefile
index b8ca1edfbc60a..f653d70674eb1 100644
--- a/Doc/Makefile
+++ b/Doc/Makefile
@@ -143,7 +143,7 @@ clean:
 venv:
 	$(PYTHON) -m venv $(VENVDIR)
 	$(VENVDIR)/bin/python3 -m pip install -U pip setuptools
-	$(VENVDIR)/bin/python3 -m pip install -U Sphinx==2.3.1 blurb python-docs-theme
+	$(VENVDIR)/bin/python3 -m pip install -r requirements.txt
 	@echo "The venv has been created in the $(VENVDIR) directory"
 
 dist:
diff --git a/Doc/requirements.txt b/Doc/requirements.txt
index 198446b350ff2..47b78eeac817e 100644
--- a/Doc/requirements.txt
+++ b/Doc/requirements.txt
@@ -1,5 +1,12 @@
-# Requirements for docs build on netlify
-# Pin sphinx to version specified in .travis.yml
-sphinx==2.2.0
+# Requirements to build the Python documentation
+
+# Sphinx version is pinned so that new versions that introduce new warnings
+# won't suddenly cause build failures. Updating the version is fine as long
+# as no warnings are raised by doing so.
+sphinx==2.4.4
+
 blurb
+
+# The theme used by the documentation is stored separately, so we need
+# to install that as well.
 python-docs-theme



More information about the Python-checkins mailing list