[PYTHON-CRYPTO] M2Crypto 0.16 mini-roadmap proposal

Guido van Rossum guido at PYTHON.ORG
Tue Feb 14 00:45:40 CET 2006

Is it really necessary to require such a recent OpenSSL version?

How about conditionally compiling the parts that don't work with older
OpenSSL versions?

If you already have an OpenSSL version installed it's rather a pain to
upgrade it -- somehow OpenSSL is a beast.


On 2/13/06, Heikki Toivonen <heikki at osafoundation.org> wrote:
> I think it would be time to start thinking about what the next M2Crypto
> release should look like. There are a few patches with some new features
> that are also waiting for checkins already, and there are some ideas for
> more stuff as well.
> Some of the new features that are waiting checkin depend on OpenSSL 0.9.8.
> There are also a bunch of cleanup work that could be done if support for
> older Python and SWIG versions were dropped.
> Therefore I think M2Crypto 0.16 should require:
>   * OpenSSL 0.9.8 or newer
>   * Python 2.3 or newer
>   * SWIG (not sure what yet)
> The 0.15 branch would naturally remain available for older versions of
> those, and if there is demand/need maintenance releases could be made to
> fix security issues and the like.
> As for timeline, a release sometime next summer (ideally sooner if
> possible) would be my goal.
> --
>   Heikki Toivonen

--Guido van Rossum (home page: http://www.python.org/~guido/)

More information about the python-crypto mailing list