[Python-Dev] Did something change in Makefile.in or Modules/Makefile.pre.in?

Skip Montanaro skip@mojam.com (Skip Montanaro)
Sun, 17 Dec 2000 17:55:10 -0600 (CST)


I executed cvs update today (removing the sourceforge machines from
.ssh/known_hosts worked fine for me, btw) followed by a configure and a make
clean.  The last step failed with this output:

    ...
    make[1]: Entering directory `/home/beluga/skip/src/python/dist/src/Modules'
    Makefile.pre.in:20: *** missing separator.  Stop.
    make[1]: Leaving directory `/home/beluga/skip/src/python/dist/src/Modules'
    make: [clean] Error 2 (ignored)

I found the following at line 20 of Modules/Makefile.pre.in:

    @SET_CXX@

I then tried a cvs annotate on that file but saw that line 20 had been there
since rev 1.60 (16-Dec-99).  I then checked the top-level Makefile.in
thinking something must have changed in the clean target recently, but cvs
annotate shows no recent changes there either:

    1.1          (guido    24-Dec-93): clean:		localclean
    1.1          (guido    24-Dec-93): 		-for i in $(SUBDIRS); do \
    1.74         (guido    19-May-98): 		    if test -d $$i; then \
    1.24         (guido    20-Jun-96): 			(echo making clean in subdirectory $$i; cd $$i; \
    1.4          (guido    01-Aug-94): 			 if test -f Makefile; \
    1.4          (guido    01-Aug-94): 			 then $(MAKE) clean; \
    1.4          (guido    01-Aug-94): 			 else $(MAKE) -f Makefile.*in clean; \
    1.4          (guido    01-Aug-94): 			 fi); \
    1.74         (guido    19-May-98): 		    else true; fi; \
    1.1          (guido    24-Dec-93): 		done

Make distclean succeeded so I tried the following:

    make distclean
    ./configure
    make clean

but the last step still failed.  Any idea why make clean is now failing (for
me)?  Can anyone else reproduce this problem?

Skip