> -1 from me. P=NP (Python is not Perl). "Chomp" is an > excessively cute name. > And like you said, this is too much like "rstrip" to merit a separate > method. My thoughts exactly. I can't remember _ever_ wanting to chomp() when rstrip() wasnt perfectly suitable. I'm sure it happens, but not often enough to introduce an ambiguous new function purely for "feature parity" with Perl. Mark.