[Python-Dev] re: list comprehension / pop quiz

Greg Wilson gvwilson@nevex.com
Wed, 12 Jul 2000 16:47:44 -0400 (EDT)

> Paul Prescod wrote:
> I don't think that using a function called "xmap" to build tuples is
> very intuitive to start with. What's so wrong with a builtin called
> "tuples()"?

I'm nervous about the readability of "tuple/tuples" and "map/xmap", having
sometimes misread "xrange" for "range".  (We take marks off student
assignments that contain functions whose names only differ by one letter,
don't we?)